Back to overview
Maintenance
Backend Updates
May 12, 2026 at 10:00pm UTC
–
May 13, 2026 at 12:00am UTC
Affected services
WeScope Portal Backend
WeScope Database
Resolved
May 13, 2026 at 12:00am UTC
Maintenance ended, everything is now back to normal with no impact to service observed.
Affected services
Created
May 12, 2026 at 10:00pm UTC
Access to WeScope's web application, data, and usage of the mobile app and browser extension, will be available, but you may experience some "slowness" around response times.
Affected services